BW Namespace

[image]

A Sandcastle Documented Class Library
BW Namespace
Send Feedback

[Missing <summary> documentation for "N:BW"]

Classes

 | Class | Description
Public class | BrwRdr | Class for reading a BRW-file.
Public class | ChCoord | Stores the coordinates of a channel on the MEA device layout

Interfaces

 | Interface | Description
Public interface | ISrcMeaFile | Interface exposing methods to manage source data file containing MEA data.

Enumerations

 | Enumeration | Description
Public enumeration | StreamType | Enumerates all the stream types that can be handled by the system.


BrwRdr Class

[image]

A Sandcastle Documented Class Library
BrwRdr Class
Members See Also Send Feedback
Class for reading a BRW-file.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BrwRdr : ISrcMeaFile, IDisposable
Visual Basic
Public Class BrwRdr _
    Implements ISrcMeaFile, IDisposable
Visual C++
public ref class BrwRdr : ISrcMeaFile, IDisposable

Inheritance Hierarchy

System..::..Object
BW..::..BrwRdr

See Also

BrwRdr Members
BW Namespace


BrwRdr Members

[image] [image]

A Sandcastle Documented Class Library
BrwRdr Members
BrwRdr Class Constructors Methods Fields Properties See Also Send Feedback

The BrwRdr type exposes the following members.

Constructors

 | Name | Description
Public method | BrwRdr | Constructor of the BrwRdr class.

Methods

 | Name | Description
Public method | Close | Closes the BRW-file and release resources.
Public method | Dispose()()()() | Clean up any resources being used.
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExistRawStream | Returns a value indicating whether a stream of the raw family exists.
Public method | ExistSpikeStream | Returns a value indicating whether a stream of the spike family exists.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNDetectedSpikes(ChCoord) | Returns the number of detected spikes for the specified channel.
Public method | GetNDetectedSpikes(array<ChCoord>[]()[][]) | Returns the number of detected spikes for the specified channels.
Public method | GetNRecChs | Returns the number of recorded channels for the specified StreamType.
Public method | GetRawData(ChCoord, Int64, Int64) | Returns starting from the specified frame number the number of specified frames in µVolt for the given channel.
Public method | GetRawData(array<ChCoord>[]()[][], Int64, Int64) | Returns starting from the specified frame number the number of specified frames in µV for the given list of channels.
Public method | GetRawDataADCCounts(ChCoord, Int64, Int64) | Returns starting from the specified frame number the number of specified frames in ADC counts for the given channel.
Public method | GetRawDataADCCounts(array<ChCoord>[]()[][], Int64, Int64) | Returns starting from the specified frame number the number of specified frames in ADC counts for the given list of channels.
Public method | GetRecChs | Returns the coordinates of the recorded channels for the specified StreamType.
Public method | GetRecChsIntersection | Returns an array of channels coordinates that are computed by considering the intersection of the recorded channels for each existing streams (in case of only one existing stream, returns the channels recorded for that stream).
Public method | GetRecChsUnion | Returns an array of channels coordinates that are computed by considering the union of the recorded channels for each existing streams.
Public method | GetRecPos | Returns the positions of the recorded channels for the specified StreamType as a bidimensional array.
Public method | GetSpikes(ChCoord, Int64, Int64) | Returns an array of values representing the timestamps in number of frames of the spikes found within the given range for the given channel.
Public method | GetSpikes(array<ChCoord>[]()[][], Int64, Int64) | Returns for every specified channel, an array of values representing the timestamps in number of frames of the spikes found within the given range.
Public method | GetTotNRecChs | Returns the total number of recorded channels considering the union of the recorded channels for each existing streams.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsRawStreamFor | Returns a value indicating whether a raw recorded stream exists for the specified channel.
Public method | IsSpikeStreamFor | Returns a value indicating whether a spike recorded stream exists for the specified channel.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Open | Opens the specified BRW-file and return a value indicating whether the opening was successful.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
HEADER_BEGINNING_LENGTH | Length for the header beginning.
HEADER_GUID_LENGTH | The length of the GUID (global unique identifier).

Properties

 | Name | Description
Public property | BitDepth | Gets the number of bits used to represent a single sample (the levels of quantization, i.e. the signal resolution, are equal to 2 raised to the bit depth power).
Public property | CanRead | Gets a value indicating whether the opened file can be read; it returns -1 in case of inaccessible file, 0 in case of not valid file format and 1 in case of valid file format.
Public property | MeaDeviceLayout | Gets the layout of the MEA device by setting to true the existing channel positions.
Public property | MeaDeviceLayoutNColumns | Get the number of columns of the MEA device layout.
Public property | MeaDeviceLayoutNRows | Gets the number of rows of the MEA device layout.
Public property | NBytesPerChSample | Gets the number of bytes used to store a sample into the hard disk.
Public property | NStreams | Gets the number of streams within the file.
Public property | RecDuration | Gets the duration in milliseconds of the acquired data.
Public property | RecNFrames | Gets the number of recorded frames.
Public property | SamplingRate | Returns the sampling frequency in Hz used to record data.
Public property | StreamTypes | Gets an array of StreamType ordered as the streams within the file.

See Also

BrwRdr Class


BrwRdr Constructor

[image]

A Sandcastle Documented Class Library
BrwRdr Constructor
BrwRdr Class See Also Send Feedback
Constructor of the BrwRdr class.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BrwRdr()
Visual Basic
Public Sub New
Visual C++
public:
BrwRdr()

See Also

BrwRdr Class


BrwRdr Fields

[image] [image]

A Sandcastle Documented Class Library
BrwRdr Fields
BrwRdr Class See Also Send Feedback

The BrwRdr type exposes the following members.

Fields

Name | Description
HEADER_BEGINNING_LENGTH | Length for the header beginning.
HEADER_GUID_LENGTH | The length of the GUID (global unique identifier).

See Also

BrwRdr Class


HEADER_BEGINNING_LENGTH Field

[image]

A Sandcastle Documented Class Library
BrwRdr..::..HEADER_BEGINNING_LENGTH Field
BrwRdr Class See Also Send Feedback
Length for the header beginning.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public const int HEADER_BEGINNING_LENGTH
Visual Basic
Public Const HEADER_BEGINNING_LENGTH As Integer
Visual C++
public:
literal int HEADER_BEGINNING_LENGTH

See Also

BrwRdr Class


HEADER_GUID_LENGTH Field

[image]

A Sandcastle Documented Class Library
BrwRdr..::..HEADER_GUID_LENGTH Field
BrwRdr Class See Also Send Feedback
The length of the GUID (global unique identifier).

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public const int HEADER_GUID_LENGTH
Visual Basic
Public Const HEADER_GUID_LENGTH As Integer
Visual C++
public:
literal int HEADER_GUID_LENGTH

See Also

BrwRdr Class


BrwRdr Methods

[image] [image]

A Sandcastle Documented Class Library
BrwRdr Methods
BrwRdr Class See Also Send Feedback

The BrwRdr type exposes the following members.

Methods

 | Name | Description
Public method | Close | Closes the BRW-file and release resources.
Public method | Dispose()()()() | Clean up any resources being used.
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExistRawStream | Returns a value indicating whether a stream of the raw family exists.
Public method | ExistSpikeStream | Returns a value indicating whether a stream of the spike family exists.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNDetectedSpikes(ChCoord) | Returns the number of detected spikes for the specified channel.
Public method | GetNDetectedSpikes(array<ChCoord>[]()[][]) | Returns the number of detected spikes for the specified channels.
Public method | GetNRecChs | Returns the number of recorded channels for the specified StreamType.
Public method | GetRawData(ChCoord, Int64, Int64) | Returns starting from the specified frame number the number of specified frames in µVolt for the given channel.
Public method | GetRawData(array<ChCoord>[]()[][], Int64, Int64) | Returns starting from the specified frame number the number of specified frames in µV for the given list of channels.
Public method | GetRawDataADCCounts(ChCoord, Int64, Int64) | Returns starting from the specified frame number the number of specified frames in ADC counts for the given channel.
Public method | GetRawDataADCCounts(array<ChCoord>[]()[][], Int64, Int64) | Returns starting from the specified frame number the number of specified frames in ADC counts for the given list of channels.
Public method | GetRecChs | Returns the coordinates of the recorded channels for the specified StreamType.
Public method | GetRecChsIntersection | Returns an array of channels coordinates that are computed by considering the intersection of the recorded channels for each existing streams (in case of only one existing stream, returns the channels recorded for that stream).
Public method | GetRecChsUnion | Returns an array of channels coordinates that are computed by considering the union of the recorded channels for each existing streams.
Public method | GetRecPos | Returns the positions of the recorded channels for the specified StreamType as a bidimensional array.
Public method | GetSpikes(ChCoord, Int64, Int64) | Returns an array of values representing the timestamps in number of frames of the spikes found within the given range for the given channel.
Public method | GetSpikes(array<ChCoord>[]()[][], Int64, Int64) | Returns for every specified channel, an array of values representing the timestamps in number of frames of the spikes found within the given range.
Public method | GetTotNRecChs | Returns the total number of recorded channels considering the union of the recorded channels for each existing streams.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsRawStreamFor | Returns a value indicating whether a raw recorded stream exists for the specified channel.
Public method | IsSpikeStreamFor | Returns a value indicating whether a spike recorded stream exists for the specified channel.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Open | Opens the specified BRW-file and return a value indicating whether the opening was successful.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BrwRdr Class


Close Method

[image]

A Sandcastle Documented Class Library
BrwRdr..::..Close Method
BrwRdr Class See Also Send Feedback
Closes the BRW-file and release resources.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Close()
Visual Basic
Public Sub Close
Visual C++
public:
virtual void Close() sealed

Implements

ISrcMeaFile..::..Close()()()()

See Also

BrwRdr Class


Dispose Method

[image] [image]

A Sandcastle Documented Class Library
BrwRdr..::..Dispose Method
BrwRdr Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Clean up any resources being used.
Protected method | Dispose(Boolean) | Clean up any resources being used.

See Also

BrwRdr Class
BrwRdr Members


Dispose Method

[image]

A Sandcastle Documented Class Library
BrwRdr..::..Dispose Method
BrwRdr Class See Also Send Feedback
Clean up any resources being used.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

BrwRdr Class
Dispose Overload


Dispose Method (Boolean)

[image]

A Sandcastle Documented Class Library
BrwRdr..::..Dispose Method (Boolean)
BrwRdr Class See Also Send Feedback
Clean up any resources being used.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual void Dispose(
    bool disposing
)
Visual Basic
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::..Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

BrwRdr Class
Dispose Overload


ExistRawStream Method

[image]

A Sandcastle Documented Class Library
BrwRdr..::..ExistRawStream Method
BrwRdr Class See Also Send Feedback
Returns a value indicating whether a stream of the raw family exists.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ExistRawStream()
Visual Basic
Public Function ExistRawStream As Boolean
Visual C++
public:
virtual bool ExistRawStream() sealed

Return Value

A value indicating whether a stream of type raw exist.

Implements

ISrcMeaFile..::..ExistRawStream()()()()

See Also

BrwRdr Class


ExistSpikeStream Method

[image]

A Sandcastle Documented Class Library
BrwRdr..::..ExistSpikeStream Method
BrwRdr Class See Also Send Feedback
Returns a value indicating whether a stream of the spike family exists.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ExistSpikeStream()
Visual Basic
Public Function ExistSpikeStream As Boolean
Visual C++
public:
virtual bool ExistSpikeStream() sealed

Return Value

A value indicating whether a stream of type spike exist.

Implements

ISrcMeaFile..::..ExistSpikeStream()()()()

See Also

BrwRdr Class


GetNDetectedSpikes Method

[image] [image]

A Sandcastle Documented Class Library
BrwRdr..::..GetNDetectedSpikes Method
BrwRdr Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetNDetectedSpikes(ChCoord) | Returns the number of detected spikes for the specified channel.
Public method | GetNDetectedSpikes(array<ChCoord>[]()[][]) | Returns the number of detected spikes for the specified channels.

See Also

BrwRdr Class
BrwRdr Members


GetNDetectedSpikes Method (ChCoord)

[image]

A Sandcastle Documented Class Library
BrwRdr..::..GetNDetectedSpikes Method (ChCoord)
BrwRdr Class See Also Send Feedback
Returns the number of detected spikes for the specified channel.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int GetNDetectedSpikes(
    ChCoord chCoord
)
Visual Basic
Public Function GetNDetectedSpikes ( _
    chCoord As ChCoord _
) As Integer
Visual C++
public:
virtual int GetNDetectedSpikes(
    ChCoord^ chCoord
) sealed

Parameters

chCoord
Type: BW..::..ChCoord
The coordinates of the channels for which the number of deteted spikes are returned.

Return Value

The number of detected spikes for the given channel.

Implements

ISrcMeaFile..::..GetNDetectedSpikes(ChCoord)

See Also

BrwRdr Class
GetNDetectedSpikes Overload


GetNDetectedSpikes Method (ChCoord[])

[image]

A Sandcastle Documented Class Library
BrwRdr..::..GetNDetectedSpikes Method (array<ChCoord>[]()[][])
BrwRdr Class See Also Send Feedback
Returns the number of detected spikes for the specified channels.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int[] GetNDetectedSpikes(
    ChCoord[] chCoords
)
Visual Basic
Public Function GetNDetectedSpikes ( _
    chCoords As ChCoord() _
) As Integer()
Visual C++
public:
virtual array<int>^ GetNDetectedSpikes(
    array<ChCoord^>^ chCoords
) sealed

Parameters

chCoords
Type: array< BW..::..ChCoord >[]()[][]
An array cointaining the coordinates of the channels for which the number of deteted spikes are returned.

Return Value

An array of values giving the number of detected spikes for each channel.

Implements

ISrcMeaFile..::..GetNDetectedSpikes(array<ChCoord>[]()[][])

See Also

BrwRdr Class
GetNDetectedSpikes Overload


GetNRecChs Method

[image]

A Sandcastle Documented Class Library
BrwRdr..::..GetNRecChs Method
BrwRdr Class See Also Send Feedback
Returns the number of recorded channels for the specified StreamType.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int GetNRecChs(
    StreamType streamType
)
Visual Basic
Public Function GetNRecChs ( _
    streamType As StreamType _
) As Integer
Visual C++
public:
virtual int GetNRecChs(
    StreamType streamType
) sealed

Parameters

streamType
Type: BW..::..StreamType

[Missing <param name="streamType"/> documentation for "M:BW.BrwRdr.GetNRecChs(BW.StreamType)"]

Return Value

The number of recorded channels.

Implements

ISrcMeaFile..::..GetNRecChs(StreamType)

See Also

BrwRdr Class


GetRawData Method

[image] [image]

A Sandcastle Documented Class Library
BrwRdr..::..GetRawData Method
BrwRdr Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRawData(ChCoord, Int64, Int64) | Returns starting from the specified frame number the number of specified frames in µVolt for the given channel.
Public method | GetRawData(array<ChCoord>[]()[][], Int64, Int64) | Returns starting from the specified frame number the number of specified frames in µV for the given list of channels.

See Also

BrwRdr Class
BrwRdr Members


GetRawData Method (ChCoord, Int64, Int64)

[image]

A Sandcastle Documented Class Library
BrwRdr..::..GetRawData Method (ChCoord, Int64, Int64)
BrwRdr Class See Also Send Feedback
Returns starting from the specified frame number the number of specified frames in µVolt for the given channel.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double[] GetRawData(
    ChCoord chCoord,
    long nFramesOffset,
    long nFrames
)
Visual Basic
Public Function GetRawData ( _
    chCoord As ChCoord, _
    nFramesOffset As Long, _
    nFrames As Long _
) As Double()
Visual C++
public:
virtual array<double>^ GetRawData(
    ChCoord^ chCoord,
    long long nFramesOffset,
    long long nFrames
) sealed

Parameters

chCoord
Type: BW..::..ChCoord
The coordinates of the channel for which data are returned.
nFramesOffset
Type: System..::..Int64
The frame offset where to start to read data.
nFrames
Type: System..::..Int64
The number of frames to return.

Return Value

An array containing recorded data in µV.

Implements

ISrcMeaFile..::..GetRawData(ChCoord, Int64, Int64)

See Also

BrwRdr Class
GetRawData Overload


GetRawData Method (ChCoord[], Int64, Int64)

[image]

A Sandcastle Documented Class Library
BrwRdr..::..GetRawData Method (array<ChCoord>[]()[][], Int64, Int64)
BrwRdr Class See Also Send Feedback
Returns starting from the specified frame number the number of specified frames in µV for the given list of channels.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double[][] GetRawData(
    ChCoord[] chCoords,
    long nFramesOffset,
    long nFrames
)
Visual Basic
Public Function GetRawData ( _
    chCoords As ChCoord(), _
    nFramesOffset As Long, _
    nFrames As Long _
) As Double()()
Visual C++
public:
virtual array<array<double>^>^ GetRawData(
    array<ChCoord^>^ chCoords,
    long long nFramesOffset,
    long long nFrames
) sealed

Parameters

chCoords
Type: array< BW..::..ChCoord >[]()[][]
An array cointaining the coordinates of the channels for which data are returned.
nFramesOffset
Type: System..::..Int64
The frame offset where to start to read data.
nFrames
Type: System..::..Int64
The number of frames to return.

Return Value

An array of arrays where each nested array contains recorded data in µV for the corresponding channel.

Implements

ISrcMeaFile..::..GetRawData(array<ChCoord>[]()[][], Int64, Int64)

See Also

BrwRdr Class
GetRawData Overload


GetRawDataADCCounts Method

[image] [image]

A Sandcastle Documented Class Library
BrwRdr..::..GetRawDataADCCounts Method
BrwRdr Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRawDataADCCounts(ChCoord, Int64, Int64) | Returns starting from the specified frame number the number of specified frames in ADC counts for the given channel.
Public method | GetRawDataADCCounts(array<ChCoord>[]()[][], Int64, Int64) | Returns starting from the specified frame number the number of specified frames in ADC counts for the given list of channels.

See Also

BrwRdr Class
BrwRdr Members


GetRawDataADCCounts Method (ChCoord, Int64, Int64)

[image]

A Sandcastle Documented Class Library
BrwRdr..::..GetRawDataADCCounts Method (ChCoord, Int64, Int64)
BrwRdr Class See Also Send Feedback
Returns starting from the specified frame number the number of specified frames in ADC counts for the given channel.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public short[] GetRawDataADCCounts(
    ChCoord chCoord,
    long nFramesOffset,
    long nFrames
)
Visual Basic
Public Function GetRawDataADCCounts ( _
    chCoord As ChCoord, _
    nFramesOffset As Long, _
    nFrames As Long _
) As Short()
Visual C++
public:
virtual array<short>^ GetRawDataADCCounts(
    ChCoord^ chCoord,
    long long nFramesOffset,
    long long nFrames
) sealed

Parameters

chCoord
Type: BW..::..ChCoord
The coordinates of the channel for which data are returned.
nFramesOffset
Type: System..::..Int64
The frame offset where to start to read data.
nFrames
Type: System..::..Int64
The number of frames to return.

Return Value

An array containing recorded data in ADC counts.

Implements

ISrcMeaFile..::..GetRawDataADCCounts(ChCoord, Int64, Int64)

See Also

BrwRdr Class
GetRawDataADCCounts Overload


GetRawDataADCCounts Method (ChCoord[], Int64, Int64)

[image]

A Sandcastle Documented Class Library
BrwRdr..::..GetRawDataADCCounts Method (array<ChCoord>[]()[][], Int64, Int64)
BrwRdr Class See Also Send Feedback
Returns starting from the specified frame number the number of specified frames in ADC counts for the given list of channels.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public short[][] GetRawDataADCCounts(
    ChCoord[] chCoords,
    long nFramesOffset,
    long nFrames
)
Visual Basic
Public Function GetRawDataADCCounts ( _
    chCoords As ChCoord(), _
    nFramesOffset As Long, _
    nFrames As Long _
) As Short()()
Visual C++
public:
virtual array<array<short>^>^ GetRawDataADCCounts(
    array<ChCoord^>^ chCoords,
    long long nFramesOffset,
    long long nFrames
) sealed

Parameters

chCoords
Type: array< BW..::..ChCoord >[]()[][]

[Missing <param name="chCoords"/> documentation for "M:BW.BrwRdr.GetRawDataADCCounts(BW.ChCoord[],System.Int64,System.Int64)"]

nFramesOffset
Type: System..::..Int64

[Missing <param name="nFramesOffset"/> documentation for "M:BW.BrwRdr.GetRawDataADCCounts(BW.ChCoord[],System.Int64,System.Int64)"]

nFrames
Type: System..::..Int64

[Missing <param name="nFrames"/> documentation for "M:BW.BrwRdr.GetRawDataADCCounts(BW.ChCoord[],System.Int64,System.Int64)"]

Return Value

A bidimensional array containing recorded data in ADC counts.

Implements

ISrcMeaFile..::..GetRawDataADCCounts(array<ChCoord>[]()[][], Int64, Int64)

See Also

BrwRdr Class
GetRawDataADCCounts Overload


GetRecChs Method

[image]

A Sandcastle Documented Class Library
BrwRdr..::..GetRecChs Method
BrwRdr Class See Also Send Feedback
Returns the coordinates of the recorded channels for the specified StreamType.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ChCoord[] GetRecChs(
    StreamType streamType
)
Visual Basic
Public Function GetRecChs ( _
    streamType As StreamType _
) As ChCoord()
Visual C++
public:
virtual array<ChCoord^>^ GetRecChs(
    StreamType streamType
) sealed

Parameters

streamType
Type: BW..::..StreamType

[Missing <param name="streamType"/> documentation for "M:BW.BrwRdr.GetRecChs(BW.StreamType)"]

Return Value

An array containing the coordinates of the recorded channels.

Implements

ISrcMeaFile..::..GetRecChs(StreamType)

See Also

BrwRdr Class


GetRecChsIntersection Method

[image]

A Sandcastle Documented Class Library
BrwRdr..::..GetRecChsIntersection Method
BrwRdr Class See Also Send Feedback
Returns an array of channels coordinates that are computed by considering the intersection of the recorded channels for each existing streams (in case of only one existing stream, returns the channels recorded for that stream).

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ChCoord[] GetRecChsIntersection()
Visual Basic
Public Function GetRecChsIntersection As ChCoord()
Visual C++
public:
virtual array<ChCoord^>^ GetRecChsIntersection() sealed

Return Value

The array of all the recorded channels.

Implements

ISrcMeaFile..::..GetRecChsIntersection()()()()

See Also

BrwRdr Class


GetRecChsUnion Method

[image]

A Sandcastle Documented Class Library
BrwRdr..::..GetRecChsUnion Method
BrwRdr Class See Also Send Feedback
Returns an array of channels coordinates that are computed by considering the union of the recorded channels for each existing streams.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ChCoord[] GetRecChsUnion()
Visual Basic
Public Function GetRecChsUnion As ChCoord()
Visual C++
public:
virtual array<ChCoord^>^ GetRecChsUnion() sealed

Return Value

The array of all the recorded channels.

Implements

ISrcMeaFile..::..GetRecChsUnion()()()()

See Also

BrwRdr Class


GetRecPos Method

[image]

A Sandcastle Documented Class Library
BrwRdr..::..GetRecPos Method
BrwRdr Class See Also Send Feedback
Returns the positions of the recorded channels for the specified StreamType as a bidimensional array.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public short[,] GetRecPos(
    StreamType streamType
)
Visual Basic
Public Function GetRecPos ( _
    streamType As StreamType _
) As Short(,)
Visual C++
public:
virtual array<short,2>^ GetRecPos(
    StreamType streamType
) sealed

Parameters

streamType
Type: BW..::..StreamType

[Missing <param name="streamType"/> documentation for "M:BW.BrwRdr.GetRecPos(BW.StreamType)"]

Return Value

A bidimensional Nx2 array for N channel positions having in the first column the row position within the MEA of the channel and in the second column the columun position within the MEA of the channel.

Implements

ISrcMeaFile..::..GetRecPos(StreamType)

See Also

BrwRdr Class


GetSpikes Method

[image] [image]

A Sandcastle Documented Class Library
BrwRdr..::..GetSpikes Method
BrwRdr Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetSpikes(ChCoord, Int64, Int64) | Returns an array of values representing the timestamps in number of frames of the spikes found within the given range for the given channel.
Public method | GetSpikes(array<ChCoord>[]()[][], Int64, Int64) | Returns for every specified channel, an array of values representing the timestamps in number of frames of the spikes found within the given range.

See Also

BrwRdr Class
BrwRdr Members


GetSpikes Method (ChCoord, Int64, Int64)

[image]

A Sandcastle Documented Class Library
BrwRdr..::..GetSpikes Method (ChCoord, Int64, Int64)
BrwRdr Class See Also Send Feedback
Returns an array of values representing the timestamps in number of frames of the spikes found within the given range for the given channel.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public long[] GetSpikes(
    ChCoord chCoord,
    long fromFrameInclusive,
    long toFrameExclusive
)
Visual Basic
Public Function GetSpikes ( _
    chCoord As ChCoord, _
    fromFrameInclusive As Long, _
    toFrameExclusive As Long _
) As Long()
Visual C++
public:
virtual array<long long>^ GetSpikes(
    ChCoord^ chCoord,
    long long fromFrameInclusive,
    long long toFrameExclusive
) sealed

Parameters

chCoord
Type: BW..::..ChCoord
The coordinates of the channels for which the deteted spikes are returned.
fromFrameInclusive
Type: System..::..Int64
The frame (included) where to start to search for spikes.
toFrameExclusive
Type: System..::..Int64
The frame (excluded) where to stop to search for spikes.

Return Value

An array of timestamps for the detected spikes for the given channel.

Implements

ISrcMeaFile..::..GetSpikes(ChCoord, Int64, Int64)

See Also

BrwRdr Class
GetSpikes Overload


GetSpikes Method (ChCoord[], Int64, Int64)

[image]

A Sandcastle Documented Class Library
BrwRdr..::..GetSpikes Method (array<ChCoord>[]()[][], Int64, Int64)
BrwRdr Class See Also Send Feedback
Returns for every specified channel, an array of values representing the timestamps in number of frames of the spikes found within the given range.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public long[][] GetSpikes(
    ChCoord[] chCoords,
    long fromFrameInclusive,
    long toFrameExclusive
)
Visual Basic
Public Function GetSpikes ( _
    chCoords As ChCoord(), _
    fromFrameInclusive As Long, _
    toFrameExclusive As Long _
) As Long()()
Visual C++
public:
virtual array<array<long long>^>^ GetSpikes(
    array<ChCoord^>^ chCoords,
    long long fromFrameInclusive,
    long long toFrameExclusive
) sealed

Parameters

chCoords
Type: array< BW..::..ChCoord >[]()[][]
An array cointaining the coordinates of the channels for which the deteted spikes are returned.
fromFrameInclusive
Type: System..::..Int64
The frame (included) where to start to search for spikes.
toFrameExclusive
Type: System..::..Int64
The frame (excluded) where to stop to search for spikes.

Return Value

An array where at each position is defined an array of timestamps for the detected spikes for the corresponding channel.

Implements

ISrcMeaFile..::..GetSpikes(array<ChCoord>[]()[][], Int64, Int64)

See Also

BrwRdr Class
GetSpikes Overload


GetTotNRecChs Method

[image]

A Sandcastle Documented Class Library
BrwRdr..::..GetTotNRecChs Method
BrwRdr Class See Also Send Feedback
Returns the total number of recorded channels considering the union of the recorded channels for each existing streams.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int GetTotNRecChs()
Visual Basic
Public Function GetTotNRecChs As Integer
Visual C++
public:
virtual int GetTotNRecChs() sealed

Return Value

The total number of recorded channels.

Implements

ISrcMeaFile..::..GetTotNRecChs()()()()

See Also

BrwRdr Class


IsRawStreamFor Method

[image]

A Sandcastle Documented Class Library
BrwRdr..::..IsRawStreamFor Method
BrwRdr Class See Also Send Feedback
Returns a value indicating whether a raw recorded stream exists for the specified channel.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsRawStreamFor(
    ChCoord chCoord
)
Visual Basic
Public Function IsRawStreamFor ( _
    chCoord As ChCoord _
) As Boolean
Visual C++
public:
virtual bool IsRawStreamFor(
    ChCoord^ chCoord
) sealed

Parameters

chCoord
Type: BW..::..ChCoord
The channel coordinates.

Return Value

A value indicating whether a stream of raw type exist.

Implements

ISrcMeaFile..::..IsRawStreamFor(ChCoord)

See Also

BrwRdr Class


IsSpikeStreamFor Method

[image]

A Sandcastle Documented Class Library
BrwRdr..::..IsSpikeStreamFor Method
BrwRdr Class See Also Send Feedback
Returns a value indicating whether a spike recorded stream exists for the specified channel.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsSpikeStreamFor(
    ChCoord chCoord
)
Visual Basic
Public Function IsSpikeStreamFor ( _
    chCoord As ChCoord _
) As Boolean
Visual C++
public:
virtual bool IsSpikeStreamFor(
    ChCoord^ chCoord
) sealed

Parameters

chCoord
Type: BW..::..ChCoord
The channel coordinates.

Return Value

A value indicating whether a stream of spike type exist.

Implements

ISrcMeaFile..::..IsSpikeStreamFor(ChCoord)

See Also

BrwRdr Class


Open Method

[image]

A Sandcastle Documented Class Library
BrwRdr..::..Open Method
BrwRdr Class See Also Send Feedback
Opens the specified BRW-file and return a value indicating whether the opening was successful.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Open(
    string filePath
)
Visual Basic
Public Function Open ( _
    filePath As String _
) As Boolean
Visual C++
public:
virtual bool Open(
    String^ filePath
) sealed

Parameters

filePath
Type: System..::..String
The path of the BRW-file.

Return Value

Whether the file has been correctly opened.

Implements

ISrcMeaFile..::..Open(String)

See Also

BrwRdr Class


BrwRdr Properties

[image] [image]

A Sandcastle Documented Class Library
BrwRdr Properties
BrwRdr Class See Also Send Feedback

The BrwRdr type exposes the following members.

Properties

 | Name | Description
Public property | BitDepth | Gets the number of bits used to represent a single sample (the levels of quantization, i.e. the signal resolution, are equal to 2 raised to the bit depth power).
Public property | CanRead | Gets a value indicating whether the opened file can be read; it returns -1 in case of inaccessible file, 0 in case of not valid file format and 1 in case of valid file format.
Public property | MeaDeviceLayout | Gets the layout of the MEA device by setting to true the existing channel positions.
Public property | MeaDeviceLayoutNColumns | Get the number of columns of the MEA device layout.
Public property | MeaDeviceLayoutNRows | Gets the number of rows of the MEA device layout.
Public property | NBytesPerChSample | Gets the number of bytes used to store a sample into the hard disk.
Public property | NStreams | Gets the number of streams within the file.
Public property | RecDuration | Gets the duration in milliseconds of the acquired data.
Public property | RecNFrames | Gets the number of recorded frames.
Public property | SamplingRate | Returns the sampling frequency in Hz used to record data.
Public property | StreamTypes | Gets an array of StreamType ordered as the streams within the file.

See Also

BrwRdr Class


BitDepth Property

[image]

A Sandcastle Documented Class Library
BrwRdr..::..BitDepth Property
BrwRdr Class See Also Send Feedback
Gets the number of bits used to represent a single sample (the levels of quantization, i.e. the signal resolution, are equal to 2 raised to the bit depth power).

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int BitDepth { get; }
Visual Basic
Public ReadOnly Property BitDepth As Integer
    Get
Visual C++
public:
virtual property int BitDepth {
    int get () sealed;
}

Return Value

The number of bits.

Implements

ISrcMeaFile..::..BitDepth

See Also

BrwRdr Class


CanRead Property

[image]

A Sandcastle Documented Class Library
BrwRdr..::..CanRead Property
BrwRdr Class See Also Send Feedback
Gets a value indicating whether the opened file can be read; it returns -1 in case of inaccessible file, 0 in case of not valid file format and 1 in case of valid file format.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int CanRead { get; }
Visual Basic
Public ReadOnly Property CanRead As Integer
    Get
Visual C++
public:
property int CanRead {
    int get ();
}

See Also

BrwRdr Class


MeaDeviceLayout Property

[image]

A Sandcastle Documented Class Library
BrwRdr..::..MeaDeviceLayout Property
BrwRdr Class See Also Send Feedback
Gets the layout of the MEA device by setting to true the existing channel positions.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool[][] MeaDeviceLayout { get; }
Visual Basic
Public ReadOnly Property MeaDeviceLayout As Boolean()()
    Get
Visual C++
public:
virtual property array<array<bool>^>^ MeaDeviceLayout {
    array<array<bool>^>^ get () sealed;
}

Return Value

A bidimensional array that specifies a MEA device layout with true values at existing channel positions.

Implements

ISrcMeaFile..::..MeaDeviceLayout

See Also

BrwRdr Class


MeaDeviceLayoutNColumns Property

[image]

A Sandcastle Documented Class Library
BrwRdr..::..MeaDeviceLayoutNColumns Property
BrwRdr Class See Also Send Feedback
Get the number of columns of the MEA device layout.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int MeaDeviceLayoutNColumns { get; }
Visual Basic
Public ReadOnly Property MeaDeviceLayoutNColumns As Integer
    Get
Visual C++
public:
virtual property int MeaDeviceLayoutNColumns {
    int get () sealed;
}

Return Value

The number of columns.

Implements

ISrcMeaFile..::..MeaDeviceLayoutNColumns

See Also

BrwRdr Class


MeaDeviceLayoutNRows Property

[image]

A Sandcastle Documented Class Library
BrwRdr..::..MeaDeviceLayoutNRows Property
BrwRdr Class See Also Send Feedback
Gets the number of rows of the MEA device layout.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int MeaDeviceLayoutNRows { get; }
Visual Basic
Public ReadOnly Property MeaDeviceLayoutNRows As Integer
    Get
Visual C++
public:
virtual property int MeaDeviceLayoutNRows {
    int get () sealed;
}

Return Value

The number of rows.

Implements

ISrcMeaFile..::..MeaDeviceLayoutNRows

See Also

BrwRdr Class


NBytesPerChSample Property

[image]

A Sandcastle Documented Class Library
BrwRdr..::..NBytesPerChSample Property
BrwRdr Class See Also Send Feedback
Gets the number of bytes used to store a sample into the hard disk.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int NBytesPerChSample { get; }
Visual Basic
Public ReadOnly Property NBytesPerChSample As Integer
    Get
Visual C++
public:
virtual property int NBytesPerChSample {
    int get () sealed;
}

Return Value

The number of bytes for a single sample.

Implements

ISrcMeaFile..::..NBytesPerChSample

See Also

BrwRdr Class


NStreams Property

[image]

A Sandcastle Documented Class Library
BrwRdr..::..NStreams Property
BrwRdr Class See Also Send Feedback
Gets the number of streams within the file.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public short NStreams { get; }
Visual Basic
Public ReadOnly Property NStreams As Short
    Get
Visual C++
public:
virtual property short NStreams {
    short get () sealed;
}

Implements

ISrcMeaFile..::..NStreams

See Also

BrwRdr Class


RecDuration Property

[image]

A Sandcastle Documented Class Library
BrwRdr..::..RecDuration Property
BrwRdr Class See Also Send Feedback
Gets the duration in milliseconds of the acquired data.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double RecDuration { get; }
Visual Basic
Public ReadOnly Property RecDuration As Double
    Get
Visual C++
public:
virtual property double RecDuration {
    double get () sealed;
}

Return Value

The recording duration in milliseconds.

Implements

ISrcMeaFile..::..RecDuration

See Also

BrwRdr Class


RecNFrames Property

[image]

A Sandcastle Documented Class Library
BrwRdr..::..RecNFrames Property
BrwRdr Class See Also Send Feedback
Gets the number of recorded frames.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public long RecNFrames { get; }
Visual Basic
Public ReadOnly Property RecNFrames As Long
    Get
Visual C++
public:
virtual property long long RecNFrames {
    long long get () sealed;
}

Return Value

The number of recorded frames.

Implements

ISrcMeaFile..::..RecNFrames

See Also

BrwRdr Class


SamplingRate Property

[image]

A Sandcastle Documented Class Library
BrwRdr..::..SamplingRate Property
BrwRdr Class See Also Send Feedback
Returns the sampling frequency in Hz used to record data.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int SamplingRate { get; }
Visual Basic
Public ReadOnly Property SamplingRate As Integer
    Get
Visual C++
public:
virtual property int SamplingRate {
    int get () sealed;
}

Return Value

The sampling frequency in Hz.

Implements

ISrcMeaFile..::..SamplingRate

See Also

BrwRdr Class


StreamTypes Property

[image]

A Sandcastle Documented Class Library
BrwRdr..::..StreamTypes Property
BrwRdr Class See Also Send Feedback
Gets an array of StreamType ordered as the streams within the file.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public StreamType[] StreamTypes { get; }
Visual Basic
Public ReadOnly Property StreamTypes As StreamType()
    Get
Visual C++
public:
virtual property array<StreamType>^ StreamTypes {
    array<StreamType>^ get () sealed;
}

Implements

ISrcMeaFile..::..StreamTypes

See Also

BrwRdr Class


ChCoord Class

[image]

A Sandcastle Documented Class Library
ChCoord Class
Members See Also Send Feedback
Stores the coordinates of a channel on the MEA device layout

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[SerializableAttribute]
public class ChCoord : EqualityComparer<ChCoord>,
    ICloneable, IComparable, IComparable<ChCoord>, IEquatable<ChCoord>
Visual Basic
<SerializableAttribute> _
Public Class ChCoord _
    Inherits EqualityComparer(Of ChCoord) _
    Implements ICloneable, IComparable, IComparable(Of ChCoord),  _
    IEquatable(Of ChCoord)
Visual C++
[SerializableAttribute]
public ref class ChCoord : public EqualityComparer<ChCoord^>,
    ICloneable, IComparable, IComparable<ChCoord^>, IEquatable<ChCoord^>

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..EqualityComparer <(Of <(<'ChCoord>)>)>
BW..::..ChCoord

See Also

ChCoord Members


ChCoord Members

[image] [image]

A Sandcastle Documented Class Library
ChCoord Members
ChCoord Class Constructors Methods Operators Properties See Also Send Feedback

The ChCoord type exposes the following members.

Constructors

 | Name | Description
Public method | ChCoord | Initialize a new instance of the ChCoord class with the specified coordinates.

Methods

 | Name | Description
Public method | Clone | Returns a deep copy of the object.
Public method | CompareTo(Object) | Compares this instance to the specified ChCoord object and returns an indication of their relative values.
Public method | CompareTo(ChCoord) | Compares this instance to the specified other ChCoord and returns an indication of their relative values.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(ChCoord) | Determines whether the specified ChCoord is equal to the current ChCoord.
Public method | Equals(ChCoord, ChCoord) | Determines whether the two ChCoord instances are equal. (Overrides EqualityComparer<(Of <(<'T>)>)>..::..Equals(T, T).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode()()()() | Returns the hash code for this instance. (Overrides Object..::..GetHashCode()()()().)
Public method | GetHashCode(ChCoord) | Returns the hash code for the specified ChCoord. (Overrides EqualityComparer<(Of <(<'T>)>)>..::..GetHashCode(T).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToArray | Convert the channel coordinate to an array with the row and the column values.
Public method | ToString()()()() | Convert the ChCoord in a representative string. (Overrides Object..::..ToString()()()().)
Public method | ToString(String) | Convert the ChCoord in a representative string using the specified separator

Operators

Name | Description
Equality | Return a value indicating whetehr the two ChCoord are equal.
ExplicitNarrowingExplicitExplicitExplicit(String to ChCoord) | Explicit boxing returning the ChCoord represented from the specified string.
ExplicitNarrowingExplicitExplicitExplicit(ChCoord to String) | Explicit boxing of a ChCoord returning a representative string.
Inequality | Return a value indicating whetehr the two ChCoord are not equal.

Properties

 | Name | Description
Public property | Col | Gets the column of the channel coordinate.
 | Empty | Returns an empty channel coordinate
Public property | Row | Gets the row of the channel coordinate.

See Also

ChCoord Class


ChCoord Constructor

[image]

A Sandcastle Documented Class Library
ChCoord Constructor
ChCoord Class See Also Send Feedback
Initialize a new instance of the ChCoord class with the specified coordinates.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ChCoord(
    int row,
    int column
)
Visual Basic
Public Sub New ( _
    row As Integer, _
    column As Integer _
)
Visual C++
public:
ChCoord(
    int row,
    int column
)

Parameters

row
Type: System..::..Int32
The row of the channel (row numbers start from 1).
column
Type: System..::..Int32
The column of the channel (column numbers start from 1).

See Also

ChCoord Class


ChCoord Methods

[image] [image]

A Sandcastle Documented Class Library
ChCoord Methods
ChCoord Class See Also Send Feedback

The ChCoord type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a deep copy of the object.
Public method | CompareTo(Object) | Compares this instance to the specified ChCoord object and returns an indication of their relative values.
Public method | CompareTo(ChCoord) | Compares this instance to the specified other ChCoord and returns an indication of their relative values.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(ChCoord) | Determines whether the specified ChCoord is equal to the current ChCoord.
Public method | Equals(ChCoord, ChCoord) | Determines whether the two ChCoord instances are equal. (Overrides EqualityComparer<(Of <(<'T>)>)>..::..Equals(T, T).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode()()()() | Returns the hash code for this instance. (Overrides Object..::..GetHashCode()()()().)
Public method | GetHashCode(ChCoord) | Returns the hash code for the specified ChCoord. (Overrides EqualityComparer<(Of <(<'T>)>)>..::..GetHashCode(T).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToArray | Convert the channel coordinate to an array with the row and the column values.
Public method | ToString()()()() | Convert the ChCoord in a representative string. (Overrides Object..::..ToString()()()().)
Public method | ToString(String) | Convert the ChCoord in a representative string using the specified separator

See Also

ChCoord Class


Clone Method

[image]

A Sandcastle Documented Class Library
ChCoord..::..Clone Method
ChCoord Class See Also Send Feedback
Returns a deep copy of the object.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object
Visual C++
public:
virtual Object^ Clone() sealed

Return Value

The deep copy.

Implements

ICloneable..::..Clone()()()()

See Also

ChCoord Class


CompareTo Method

[image] [image]

A Sandcastle Documented Class Library
ChCoord..::..CompareTo Method
ChCoord Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CompareTo(Object) | Compares this instance to the specified ChCoord object and returns an indication of their relative values.
Public method | CompareTo(ChCoord) | Compares this instance to the specified other ChCoord and returns an indication of their relative values.

See Also

ChCoord Class
ChCoord Members


CompareTo Method (Object)

[image]

A Sandcastle Documented Class Library
ChCoord..::..CompareTo Method (Object)
ChCoord Class See Also Send Feedback
Compares this instance to the specified ChCoord object and returns an indication of their relative values.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic
Public Function CompareTo ( _
    obj As Object _
) As Integer
Visual C++
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:BW.ChCoord.CompareTo(System.Object)"]

Return Value

An indication of the relative values between comparing ChCoord objects.

Implements

IComparable..::..CompareTo(Object)

See Also

ChCoord Class
CompareTo Overload


CompareTo Method (ChCoord)

[image]

A Sandcastle Documented Class Library
ChCoord..::..CompareTo Method (ChCoord)
ChCoord Class See Also Send Feedback
Compares this instance to the specified other ChCoord and returns an indication of their relative values.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int CompareTo(
    ChCoord other
)
Visual Basic
Public Function CompareTo ( _
    other As ChCoord _
) As Integer
Visual C++
public:
virtual int CompareTo(
    ChCoord^ other
) sealed

Parameters

other
Type: BW..::..ChCoord

[Missing <param name="other"/> documentation for "M:BW.ChCoord.CompareTo(BW.ChCoord)"]

Return Value

An indication of the relative values between comparing ChCoord objects.

Implements

IComparable<(Of <(<'T>)>)>..::..CompareTo(T)

See Also

ChCoord Class
CompareTo Overload


Equals Method

[image] [image]

A Sandcastle Documented Class Library
ChCoord..::..Equals Method
ChCoord Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | Equals(ChCoord) | Determines whether the specified ChCoord is equal to the current ChCoord.
Public method | Equals(ChCoord, ChCoord) | Determines whether the two ChCoord instances are equal. (Overrides EqualityComparer<(Of <(<'T>)>)>..::..Equals(T, T).)

See Also

ChCoord Class
ChCoord Members


Equals Method (Object)

[image]

A Sandcastle Documented Class Library
ChCoord..::..Equals Method (Object)
ChCoord Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:BW.ChCoord.Equals(System.Object)"]

Return Value

True if the specified Object is equal to the current Object; otherwise, false.

See Also

ChCoord Class
Equals Overload


Equals Method (ChCoord)

[image]

A Sandcastle Documented Class Library
ChCoord..::..Equals Method (ChCoord)
ChCoord Class See Also Send Feedback
Determines whether the specified ChCoord is equal to the current ChCoord.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Equals(
    ChCoord other
)
Visual Basic
Public Function Equals ( _
    other As ChCoord _
) As Boolean
Visual C++
public:
virtual bool Equals(
    ChCoord^ other
) sealed

Parameters

other
Type: BW..::..ChCoord

[Missing <param name="other"/> documentation for "M:BW.ChCoord.Equals(BW.ChCoord)"]

Return Value

True if the specified ChCoord is equal to the current ChCoord; otherwise, false.

Implements

IEquatable<(Of <(<'T>)>)>..::..Equals(T)

See Also

ChCoord Class
Equals Overload


Equals Method (ChCoord, ChCoord)

[image]

A Sandcastle Documented Class Library
ChCoord..::..Equals Method (ChCoord, ChCoord)
ChCoord Class See Also Send Feedback
Determines whether the two ChCoord instances are equal.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override bool Equals(
    ChCoord x,
    ChCoord y
)
Visual Basic
Public Overrides Function Equals ( _
    x As ChCoord, _
    y As ChCoord _
) As Boolean
Visual C++
public:
virtual bool Equals(
    ChCoord^ x,
    ChCoord^ y
) override

Parameters

x
Type: BW..::..ChCoord
The first ChCoord instance.
y
Type: BW..::..ChCoord
The second ChCoord instance.

Return Value

True if the two istances are equal; otherwise, false.

Implements

IEqualityComparer<(Of <(<'T>)>)>..::..Equals(T, T)

See Also

ChCoord Class
Equals Overload


GetHashCode Method

[image] [image]

A Sandcastle Documented Class Library
ChCoord..::..GetHashCode Method
ChCoord Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetHashCode()()()() | Returns the hash code for this instance. (Overrides Object..::..GetHashCode()()()().)
Public method | GetHashCode(ChCoord) | Returns the hash code for the specified ChCoord. (Overrides EqualityComparer<(Of <(<'T>)>)>..::..GetHashCode(T).)

See Also

ChCoord Class
ChCoord Members


GetHashCode Method

[image]

A Sandcastle Documented Class Library
ChCoord..::..GetHashCode Method
ChCoord Class See Also Send Feedback
Returns the hash code for this instance.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

The hash code.

See Also

ChCoord Class
GetHashCode Overload


GetHashCode Method (ChCoord)

[image]

A Sandcastle Documented Class Library
ChCoord..::..GetHashCode Method (ChCoord)
ChCoord Class See Also Send Feedback
Returns the hash code for the specified ChCoord.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override int GetHashCode(
    ChCoord obj
)
Visual Basic
Public Overrides Function GetHashCode ( _
    obj As ChCoord _
) As Integer
Visual C++
public:
virtual int GetHashCode(
    ChCoord^ obj
) override

Parameters

obj
Type: BW..::..ChCoord
The ChCoord whose has has to be calculated.

Return Value

The hash code.

Implements

IEqualityComparer<(Of <(<'T>)>)>..::..GetHashCode(T)

See Also

ChCoord Class
GetHashCode Overload


ToArray Method

[image]

A Sandcastle Documented Class Library
ChCoord..::..ToArray Method
ChCoord Class See Also Send Feedback
Convert the channel coordinate to an array with the row and the column values.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public short[] ToArray()
Visual Basic
Public Function ToArray As Short()
Visual C++
public:
array<short>^ ToArray()

Return Value

An array containing the row and the column values.

See Also

ChCoord Class


ToString Method

[image] [image]

A Sandcastle Documented Class Library
ChCoord..::..ToString Method
ChCoord Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Convert the ChCoord in a representative string. (Overrides Object..::..ToString()()()().)
Public method | ToString(String) | Convert the ChCoord in a representative string using the specified separator

See Also

ChCoord Class
ChCoord Members


ToString Method

[image]

A Sandcastle Documented Class Library
ChCoord..::..ToString Method
ChCoord Class See Also Send Feedback
Convert the ChCoord in a representative string.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

Returns a string representative of the ChCoord suitable for all case ('_' separator).

See Also

ChCoord Class
ToString Overload


ToString Method (String)

[image]

A Sandcastle Documented Class Library
ChCoord..::..ToString Method (String)
ChCoord Class See Also Send Feedback
Convert the ChCoord in a representative string using the specified separator

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ToString(
    string separator
)
Visual Basic
Public Function ToString ( _
    separator As String _
) As String
Visual C++
public:
String^ ToString(
    String^ separator
)

Parameters

separator
Type: System..::..String

[Missing <param name="separator"/> documentation for "M:BW.ChCoord.ToString(System.String)"]

Return Value

Returns a string representative of the ChCoord using the specified separator

See Also

ChCoord Class
ToString Overload


ChCoord Operators and Type Conversions

[image] [image]

A Sandcastle Documented Class Library
ChCoord Operators and Type Conversions
ChCoord Class See Also Send Feedback

The ChCoord type exposes the following members.

Operators

Name | Description
Equality | Return a value indicating whetehr the two ChCoord are equal.
ExplicitNarrowingExplicitExplicitExplicit(String to ChCoord) | Explicit boxing returning the ChCoord represented from the specified string.
ExplicitNarrowingExplicitExplicitExplicit(ChCoord to String) | Explicit boxing of a ChCoord returning a representative string.
Inequality | Return a value indicating whetehr the two ChCoord are not equal.

See Also

ChCoord Class


Equality Operator

[image]

A Sandcastle Documented Class Library
ChCoord..::..Equality Operator
ChCoord Class See Also Send Feedback
Return a value indicating whetehr the two ChCoord are equal.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static bool operator ==(
    ChCoord x,
    ChCoord y
)
Visual Basic
Public Shared Operator = ( _
    x As ChCoord, _
    y As ChCoord _
) As Boolean
Visual C++
public:
static bool operator ==(
    ChCoord^ x,
    ChCoord^ y
)

Parameters

x
Type: BW..::..ChCoord

[Missing <param name="x"/> documentation for "M:BW.ChCoord.op_Equality(BW.ChCoord,BW.ChCoord)"]

y
Type: BW..::..ChCoord

[Missing <param name="y"/> documentation for "M:BW.ChCoord.op_Equality(BW.ChCoord,BW.ChCoord)"]

Return Value

A value indicating whether objects are equal.

See Also

ChCoord Class


Explicit Conversion Operators

[image] [image]

A Sandcastle Documented Class Library
ChCoord ExplicitNarrowingExplicitExplicitExplicit Conversion Operators
ChCoord Class See Also Send Feedback

Overload List

Name | Description
ExplicitNarrowingExplicitExplicitExplicit(String to ChCoord) | Explicit boxing returning the ChCoord represented from the specified string.
ExplicitNarrowingExplicitExplicitExplicit(ChCoord to String) | Explicit boxing of a ChCoord returning a representative string.

See Also

ChCoord Class
ChCoord Members


Explicit Conversion (String to ChCoord)

[image]

A Sandcastle Documented Class Library
ChCoord ExplicitNarrowingExplicitExplicitExplicit Conversion (String to ChCoord)
ChCoord Class See Also Send Feedback
Explicit boxing returning the ChCoord represented from the specified string.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static explicit operator ChCoord (
    string s
)
Visual Basic
Public Shared Narrowing Operator CType ( _
    s As String _
) As ChCoord
Visual C++
static explicit operator ChCoord^ (
    String^ s
)

Parameters

s
Type: System..::..String

[Missing <param name="s"/> documentation for "M:BW.ChCoord.op_Explicit(System.String)~BW.ChCoord"]

Return Value

The ChCoord.

See Also

ChCoord Class
ExplicitNarrowingExplicitExplicitExplicit Overload


Explicit Conversion (ChCoord to String)

[image]

A Sandcastle Documented Class Library
ChCoord ExplicitNarrowingExplicitExplicitExplicit Conversion (ChCoord to String)
ChCoord Class See Also Send Feedback
Explicit boxing of a ChCoord returning a representative string.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static explicit operator string (
    ChCoord ch
)
Visual Basic
Public Shared Narrowing Operator CType ( _
    ch As ChCoord _
) As String
Visual C++
static explicit operator String^ (
    ChCoord^ ch
)

Parameters

ch
Type: BW..::..ChCoord

[Missing <param name="ch"/> documentation for "M:BW.ChCoord.op_Explicit(BW.ChCoord)~System.String"]

Return Value

The representative string.

See Also

ChCoord Class
ExplicitNarrowingExplicitExplicitExplicit Overload


Inequality Operator

[image]

A Sandcastle Documented Class Library
ChCoord..::..Inequality Operator
ChCoord Class See Also Send Feedback
Return a value indicating whetehr the two ChCoord are not equal.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static bool operator !=(
    ChCoord x,
    ChCoord y
)
Visual Basic
Public Shared Operator <> ( _
    x As ChCoord, _
    y As ChCoord _
) As Boolean
Visual C++
public:
static bool operator !=(
    ChCoord^ x,
    ChCoord^ y
)

Parameters

x
Type: BW..::..ChCoord

[Missing <param name="x"/> documentation for "M:BW.ChCoord.op_Inequality(BW.ChCoord,BW.ChCoord)"]

y
Type: BW..::..ChCoord

[Missing <param name="y"/> documentation for "M:BW.ChCoord.op_Inequality(BW.ChCoord,BW.ChCoord)"]

Return Value

A value indicating whether objects are not equal.

See Also

ChCoord Class


ChCoord Properties

[image] [image]

A Sandcastle Documented Class Library
ChCoord Properties
ChCoord Class See Also Send Feedback

The ChCoord type exposes the following members.

Properties

 | Name | Description
Public property | Col | Gets the column of the channel coordinate.
 | Empty | Returns an empty channel coordinate
Public property | Row | Gets the row of the channel coordinate.

See Also

ChCoord Class


Col Property

[image]

A Sandcastle Documented Class Library
ChCoord..::..Col Property
ChCoord Class See Also Send Feedback
Gets the column of the channel coordinate.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Col { get; }
Visual Basic
Public ReadOnly Property Col As Integer
    Get
Visual C++
public:
property int Col {
    int get ();
}

See Also

ChCoord Class


Empty Property

[image]

A Sandcastle Documented Class Library
ChCoord..::..Empty Property
ChCoord Class See Also Send Feedback
Returns an empty channel coordinate

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static ChCoord Empty { get; }
Visual Basic
Public Shared ReadOnly Property Empty As ChCoord
    Get
Visual C++
public:
static property ChCoord^ Empty {
    ChCoord^ get ();
}

See Also

ChCoord Class


Row Property

[image]

A Sandcastle Documented Class Library
ChCoord..::..Row Property
ChCoord Class See Also Send Feedback
Gets the row of the channel coordinate.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Row { get; }
Visual Basic
Public ReadOnly Property Row As Integer
    Get
Visual C++
public:
property int Row {
    int get ();
}

See Also

ChCoord Class


ISrcMeaFile Interface

[image]

A Sandcastle Documented Class Library
ISrcMeaFile Interface
Members See Also Send Feedback
Interface exposing methods to manage source data file containing MEA data.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public interface ISrcMeaFile : IDisposable
Visual Basic
Public Interface ISrcMeaFile _
    Inherits IDisposable
Visual C++
public interface class ISrcMeaFile : IDisposable

See Also

ISrcMeaFile Members


ISrcMeaFile Members

[image] [image]

A Sandcastle Documented Class Library
ISrcMeaFile Members
ISrcMeaFile Interface Methods Properties See Also Send Feedback

The ISrcMeaFile type exposes the following members.

Methods

 | Name | Description
Public method | Close | Closes the BRW-file and release resources.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | ExistRawStream | Returns a value indicating whether exist a raw recorded stream.
Public method | ExistSpikeStream | Returns a value indicating whether exist a spike recorded stream.
Public method | GetNDetectedSpikes(ChCoord) | Returns the number of detected spikes for the specified channel.
Public method | GetNDetectedSpikes(array<ChCoord>[]()[][]) | Returns the number of detected spikes for the specified channels.
Public method | GetNRecChs | Returns the number of recorded channels for the specified StreamType.
Public method | GetRawData(ChCoord, Int64, Int64) | Returns starting from the specified frame number the number of specified frames in µVolt for the given channel.
Public method | GetRawData(array<ChCoord>[]()[][], Int64, Int64) | Returns starting from the specified frame number the number of specified frames in µV for the given list of channels.
Public method | GetRawDataADCCounts(ChCoord, Int64, Int64) | Returns starting from the specified frame number the number of specified frames in ADC counts for the given channel.
Public method | GetRawDataADCCounts(array<ChCoord>[]()[][], Int64, Int64) | Returns starting from the specified frame number the number of specified frames in ADC counts for the given list of channels.
Public method | GetRecChs | Returns the coordinates of the recorded channels for the specified StreamType.
Public method | GetRecChsIntersection | Returns an array of channels coordinates that are computed by considering the intersection of the recorded channels for each existing streams.
Public method | GetRecChsUnion | Returns an array of channels coordinates that are computed by considering the union of the recorded channels for each existing streams.
Public method | GetRecPos | Returns the positions of the recorded channels for the specified StreamType as a bidimensional array.
Public method | GetSpikes(ChCoord, Int64, Int64) | Returns an array of values representing the timestamps in number of frames of the spikes found within the given range for the given channel.
Public method | GetSpikes(array<ChCoord>[]()[][], Int64, Int64) | Returns for every specified channel, an array of values representing the timestamps in number of frames of the spikes found within the given range.
Public method | GetTotNRecChs | Returns the total number of recorded channels considering the union of the recorded channels for each existing streams.
Public method | IsRawStreamFor | Returns a value indicating whether a raw recorded stream exists for the specified channel.
Public method | IsSpikeStreamFor | Returns a value indicating whether a spike recorded stream exists for the specified channel.
Public method | Open | Opens the specified BRW-file and return a value indicating the whether the opening was successful.

Properties

 | Name | Description
Public property | BitDepth | Gets the number of bits used to represent a single sample (the levels of quantization, i.e. the signal resolution, are equal to 2 raised to the bit depth power).
Public property | MeaDeviceLayout | Gets the layout of the MEA device by setting to true the existing channel positions.
Public property | MeaDeviceLayoutNColumns | Get the number of columns of the MEA device layout.
Public property | MeaDeviceLayoutNRows | Gets the number of rows of the MEA device layout.
Public property | NBytesPerChSample | Gets the number of bytes used to store a sample into the hard disk.
Public property | NStreams | Gets the number of streams within the file.
Public property | RecDuration | Gets the duration in milliseconds of the acquired data.
Public property | RecNFrames | Gets the number of recorded frames.
Public property | SamplingRate | Returns the sampling frequency in Hz used to record data.
Public property | StreamTypes | Gets an array of StreamType ordered as the streams within the file.

See Also

ISrcMeaFile Interface


ISrcMeaFile Methods

[image] [image]

A Sandcastle Documented Class Library
ISrcMeaFile Methods
ISrcMeaFile Interface See Also Send Feedback

The ISrcMeaFile type exposes the following members.

Methods

 | Name | Description
Public method | Close | Closes the BRW-file and release resources.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | ExistRawStream | Returns a value indicating whether exist a raw recorded stream.
Public method | ExistSpikeStream | Returns a value indicating whether exist a spike recorded stream.
Public method | GetNDetectedSpikes(ChCoord) | Returns the number of detected spikes for the specified channel.
Public method | GetNDetectedSpikes(array<ChCoord>[]()[][]) | Returns the number of detected spikes for the specified channels.
Public method | GetNRecChs | Returns the number of recorded channels for the specified StreamType.
Public method | GetRawData(ChCoord, Int64, Int64) | Returns starting from the specified frame number the number of specified frames in µVolt for the given channel.
Public method | GetRawData(array<ChCoord>[]()[][], Int64, Int64) | Returns starting from the specified frame number the number of specified frames in µV for the given list of channels.
Public method | GetRawDataADCCounts(ChCoord, Int64, Int64) | Returns starting from the specified frame number the number of specified frames in ADC counts for the given channel.
Public method | GetRawDataADCCounts(array<ChCoord>[]()[][], Int64, Int64) | Returns starting from the specified frame number the number of specified frames in ADC counts for the given list of channels.
Public method | GetRecChs | Returns the coordinates of the recorded channels for the specified StreamType.
Public method | GetRecChsIntersection | Returns an array of channels coordinates that are computed by considering the intersection of the recorded channels for each existing streams.
Public method | GetRecChsUnion | Returns an array of channels coordinates that are computed by considering the union of the recorded channels for each existing streams.
Public method | GetRecPos | Returns the positions of the recorded channels for the specified StreamType as a bidimensional array.
Public method | GetSpikes(ChCoord, Int64, Int64) | Returns an array of values representing the timestamps in number of frames of the spikes found within the given range for the given channel.
Public method | GetSpikes(array<ChCoord>[]()[][], Int64, Int64) | Returns for every specified channel, an array of values representing the timestamps in number of frames of the spikes found within the given range.
Public method | GetTotNRecChs | Returns the total number of recorded channels considering the union of the recorded channels for each existing streams.
Public method | IsRawStreamFor | Returns a value indicating whether a raw recorded stream exists for the specified channel.
Public method | IsSpikeStreamFor | Returns a value indicating whether a spike recorded stream exists for the specified channel.
Public method | Open | Opens the specified BRW-file and return a value indicating the whether the opening was successful.

See Also

ISrcMeaFile Interface


Close Method

[image]

A Sandcastle Documented Class Library
ISrcMeaFile..::..Close Method
ISrcMeaFile Interface See Also Send Feedback
Closes the BRW-file and release resources.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
void Close()
Visual Basic
Sub Close
Visual C++
void Close()

See Also

ISrcMeaFile Interface


ExistRawStream Method

[image]

A Sandcastle Documented Class Library
ISrcMeaFile..::..ExistRawStream Method
ISrcMeaFile Interface See Also Send Feedback
Returns a value indicating whether exist a raw recorded stream.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
bool ExistRawStream()
Visual Basic
Function ExistRawStream As Boolean
Visual C++
bool ExistRawStream()

Return Value

A value indicating whether a stream of raw type exist.

See Also

ISrcMeaFile Interface


ExistSpikeStream Method

[image]

A Sandcastle Documented Class Library
ISrcMeaFile..::..ExistSpikeStream Method
ISrcMeaFile Interface See Also Send Feedback
Returns a value indicating whether exist a spike recorded stream.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
bool ExistSpikeStream()
Visual Basic
Function ExistSpikeStream As Boolean
Visual C++
bool ExistSpikeStream()

Return Value

A value indicating whether a stream of spike type exist.

See Also

ISrcMeaFile Interface


GetNDetectedSpikes Method

[image] [image]

A Sandcastle Documented Class Library
ISrcMeaFile..::..GetNDetectedSpikes Method
ISrcMeaFile Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetNDetectedSpikes(ChCoord) | Returns the number of detected spikes for the specified channel.
Public method | GetNDetectedSpikes(array<ChCoord>[]()[][]) | Returns the number of detected spikes for the specified channels.

See Also

ISrcMeaFile Interface
ISrcMeaFile Members


GetNDetectedSpikes Method (ChCoord)

[image]

A Sandcastle Documented Class Library
ISrcMeaFile..::..GetNDetectedSpikes Method (ChCoord)
ISrcMeaFile Interface See Also Send Feedback
Returns the number of detected spikes for the specified channel.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
int GetNDetectedSpikes(
    ChCoord chCoord
)
Visual Basic
Function GetNDetectedSpikes ( _
    chCoord As ChCoord _
) As Integer
Visual C++
int GetNDetectedSpikes(
    ChCoord^ chCoord
)

Parameters

chCoord
Type: BW..::..ChCoord
The coordinates of the channels for which the number of deteted spikes are returned.

Return Value

The number of detected spikes for the given channel.

See Also

ISrcMeaFile Interface
GetNDetectedSpikes Overload


GetNDetectedSpikes Method (ChCoord[])

[image]

A Sandcastle Documented Class Library
ISrcMeaFile..::..GetNDetectedSpikes Method (array<ChCoord>[]()[][])
ISrcMeaFile Interface See Also Send Feedback
Returns the number of detected spikes for the specified channels.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
int[] GetNDetectedSpikes(
    ChCoord[] chCoords
)
Visual Basic
Function GetNDetectedSpikes ( _
    chCoords As ChCoord() _
) As Integer()
Visual C++
array<int>^ GetNDetectedSpikes(
    array<ChCoord^>^ chCoords
)

Parameters

chCoords
Type: array< BW..::..ChCoord >[]()[][]
An array cointaining the coordinates of the channels for which the number of deteted spikes are returned.

Return Value

An array of values giving the number of detected spikes for each channel.

See Also

ISrcMeaFile Interface
GetNDetectedSpikes Overload


GetNRecChs Method

[image]

A Sandcastle Documented Class Library
ISrcMeaFile..::..GetNRecChs Method
ISrcMeaFile Interface See Also Send Feedback
Returns the number of recorded channels for the specified StreamType.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
int GetNRecChs(
    StreamType streamType
)
Visual Basic
Function GetNRecChs ( _
    streamType As StreamType _
) As Integer
Visual C++
int GetNRecChs(
    StreamType streamType
)

Parameters

streamType
Type: BW..::..StreamType

[Missing <param name="streamType"/> documentation for "M:BW.ISrcMeaFile.GetNRecChs(BW.StreamType)"]

Return Value

The number of recorded channels.

See Also

ISrcMeaFile Interface


GetRawData Method

[image] [image]

A Sandcastle Documented Class Library
ISrcMeaFile..::..GetRawData Method
ISrcMeaFile Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRawData(ChCoord, Int64, Int64) | Returns starting from the specified frame number the number of specified frames in µVolt for the given channel.
Public method | GetRawData(array<ChCoord>[]()[][], Int64, Int64) | Returns starting from the specified frame number the number of specified frames in µV for the given list of channels.

See Also

ISrcMeaFile Interface
ISrcMeaFile Members


GetRawData Method (ChCoord, Int64, Int64)

[image]

A Sandcastle Documented Class Library
ISrcMeaFile..::..GetRawData Method (ChCoord, Int64, Int64)
ISrcMeaFile Interface See Also Send Feedback
Returns starting from the specified frame number the number of specified frames in µVolt for the given channel.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
double[] GetRawData(
    ChCoord chCoord,
    long nFramesOffset,
    long nFrames
)
Visual Basic
Function GetRawData ( _
    chCoord As ChCoord, _
    nFramesOffset As Long, _
    nFrames As Long _
) As Double()
Visual C++
array<double>^ GetRawData(
    ChCoord^ chCoord,
    long long nFramesOffset,
    long long nFrames
)

Parameters

chCoord
Type: BW..::..ChCoord
The coordinates of the channel for which data are returned.
nFramesOffset
Type: System..::..Int64
The frame offset where to start to read data.
nFrames
Type: System..::..Int64
The number of frames to return.

Return Value

An array containing recorded data in µV.

See Also

ISrcMeaFile Interface
GetRawData Overload


GetRawData Method (ChCoord[], Int64, Int64)

[image]

A Sandcastle Documented Class Library
ISrcMeaFile..::..GetRawData Method (array<ChCoord>[]()[][], Int64, Int64)
ISrcMeaFile Interface See Also Send Feedback
Returns starting from the specified frame number the number of specified frames in µV for the given list of channels.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
double[][] GetRawData(
    ChCoord[] chCoords,
    long nFramesOffset,
    long nFrames
)
Visual Basic
Function GetRawData ( _
    chCoords As ChCoord(), _
    nFramesOffset As Long, _
    nFrames As Long _
) As Double()()
Visual C++
array<array<double>^>^ GetRawData(
    array<ChCoord^>^ chCoords,
    long long nFramesOffset,
    long long nFrames
)

Parameters

chCoords
Type: array< BW..::..ChCoord >[]()[][]
An array cointaining the coordinates of the channels for which data are returned.
nFramesOffset
Type: System..::..Int64
The frame offset where to start to read data.
nFrames
Type: System..::..Int64
The number of frames to return.

Return Value

An array of arrays where each nested array contains recorded data in µV for the corresponding channel.

See Also

ISrcMeaFile Interface
GetRawData Overload


GetRawDataADCCounts Method

[image] [image]

A Sandcastle Documented Class Library
ISrcMeaFile..::..GetRawDataADCCounts Method
ISrcMeaFile Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRawDataADCCounts(ChCoord, Int64, Int64) | Returns starting from the specified frame number the number of specified frames in ADC counts for the given channel.
Public method | GetRawDataADCCounts(array<ChCoord>[]()[][], Int64, Int64) | Returns starting from the specified frame number the number of specified frames in ADC counts for the given list of channels.

See Also

ISrcMeaFile Interface
ISrcMeaFile Members


GetRawDataADCCounts Method (ChCoord, Int64, Int64)

[image]

A Sandcastle Documented Class Library
ISrcMeaFile..::..GetRawDataADCCounts Method (ChCoord, Int64, Int64)
ISrcMeaFile Interface See Also Send Feedback
Returns starting from the specified frame number the number of specified frames in ADC counts for the given channel.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
short[] GetRawDataADCCounts(
    ChCoord chCoord,
    long nFramesOffset,
    long nFrames
)
Visual Basic
Function GetRawDataADCCounts ( _
    chCoord As ChCoord, _
    nFramesOffset As Long, _
    nFrames As Long _
) As Short()
Visual C++
array<short>^ GetRawDataADCCounts(
    ChCoord^ chCoord,
    long long nFramesOffset,
    long long nFrames
)

Parameters

chCoord
Type: BW..::..ChCoord
The coordinates of the channel for which data are returned.
nFramesOffset
Type: System..::..Int64
The frame offset where to start to read data.
nFrames
Type: System..::..Int64
The number of frames to return.

Return Value

An array containing recorded data in ADC counts.

See Also

ISrcMeaFile Interface
GetRawDataADCCounts Overload


GetRawDataADCCounts Method (ChCoord[], Int64, Int64)

[image]

A Sandcastle Documented Class Library
ISrcMeaFile..::..GetRawDataADCCounts Method (array<ChCoord>[]()[][], Int64, Int64)
ISrcMeaFile Interface See Also Send Feedback
Returns starting from the specified frame number the number of specified frames in ADC counts for the given list of channels.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
short[][] GetRawDataADCCounts(
    ChCoord[] chCoords,
    long nFramesOffset,
    long nFrames
)
Visual Basic
Function GetRawDataADCCounts ( _
    chCoords As ChCoord(), _
    nFramesOffset As Long, _
    nFrames As Long _
) As Short()()
Visual C++
array<array<short>^>^ GetRawDataADCCounts(
    array<ChCoord^>^ chCoords,
    long long nFramesOffset,
    long long nFrames
)

Parameters

chCoords
Type: array< BW..::..ChCoord >[]()[][]

[Missing <param name="chCoords"/> documentation for "M:BW.ISrcMeaFile.GetRawDataADCCounts(BW.ChCoord[],System.Int64,System.Int64)"]

nFramesOffset
Type: System..::..Int64

[Missing <param name="nFramesOffset"/> documentation for "M:BW.ISrcMeaFile.GetRawDataADCCounts(BW.ChCoord[],System.Int64,System.Int64)"]

nFrames
Type: System..::..Int64

[Missing <param name="nFrames"/> documentation for "M:BW.ISrcMeaFile.GetRawDataADCCounts(BW.ChCoord[],System.Int64,System.Int64)"]

Return Value

A bidimensional array containing recorded data in ADC counts.

See Also

ISrcMeaFile Interface
GetRawDataADCCounts Overload


GetRecChs Method

[image]

A Sandcastle Documented Class Library
ISrcMeaFile..::..GetRecChs Method
ISrcMeaFile Interface See Also Send Feedback
Returns the coordinates of the recorded channels for the specified StreamType.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
ChCoord[] GetRecChs(
    StreamType streamType
)
Visual Basic
Function GetRecChs ( _
    streamType As StreamType _
) As ChCoord()
Visual C++
array<ChCoord^>^ GetRecChs(
    StreamType streamType
)

Parameters

streamType
Type: BW..::..StreamType

[Missing <param name="streamType"/> documentation for "M:BW.ISrcMeaFile.GetRecChs(BW.StreamType)"]

Return Value

An array containing the coordinates of the recorded channels.

See Also

ISrcMeaFile Interface


GetRecChsIntersection Method

[image]

A Sandcastle Documented Class Library
ISrcMeaFile..::..GetRecChsIntersection Method
ISrcMeaFile Interface See Also Send Feedback
Returns an array of channels coordinates that are computed by considering the intersection of the recorded channels for each existing streams.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
ChCoord[] GetRecChsIntersection()
Visual Basic
Function GetRecChsIntersection As ChCoord()
Visual C++
array<ChCoord^>^ GetRecChsIntersection()

Return Value

The array of all the recorded channels.

See Also

ISrcMeaFile Interface


GetRecChsUnion Method

[image]

A Sandcastle Documented Class Library
ISrcMeaFile..::..GetRecChsUnion Method
ISrcMeaFile Interface See Also Send Feedback
Returns an array of channels coordinates that are computed by considering the union of the recorded channels for each existing streams.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
ChCoord[] GetRecChsUnion()
Visual Basic
Function GetRecChsUnion As ChCoord()
Visual C++
array<ChCoord^>^ GetRecChsUnion()

Return Value

The array of all the recorded channels.

See Also

ISrcMeaFile Interface


GetRecPos Method

[image]

A Sandcastle Documented Class Library
ISrcMeaFile..::..GetRecPos Method
ISrcMeaFile Interface See Also Send Feedback
Returns the positions of the recorded channels for the specified StreamType as a bidimensional array.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
short[,] GetRecPos(
    StreamType streamType
)
Visual Basic
Function GetRecPos ( _
    streamType As StreamType _
) As Short(,)
Visual C++
array<short,2>^ GetRecPos(
    StreamType streamType
)

Parameters

streamType
Type: BW..::..StreamType

[Missing <param name="streamType"/> documentation for "M:BW.ISrcMeaFile.GetRecPos(BW.StreamType)"]

Return Value

A bidimensional Nx2 array for N channel positions having in the first column the row position within the MEA of the channel and in the second column the columun position within the MEA of the channel.

See Also

ISrcMeaFile Interface


GetSpikes Method

[image] [image]

A Sandcastle Documented Class Library
ISrcMeaFile..::..GetSpikes Method
ISrcMeaFile Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetSpikes(ChCoord, Int64, Int64) | Returns an array of values representing the timestamps in number of frames of the spikes found within the given range for the given channel.
Public method | GetSpikes(array<ChCoord>[]()[][], Int64, Int64) | Returns for every specified channel, an array of values representing the timestamps in number of frames of the spikes found within the given range.

See Also

ISrcMeaFile Interface
ISrcMeaFile Members


GetSpikes Method (ChCoord, Int64, Int64)

[image]

A Sandcastle Documented Class Library
ISrcMeaFile..::..GetSpikes Method (ChCoord, Int64, Int64)
ISrcMeaFile Interface See Also Send Feedback
Returns an array of values representing the timestamps in number of frames of the spikes found within the given range for the given channel.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
long[] GetSpikes(
    ChCoord chCoord,
    long fromFrameInclusive,
    long toFrameExclusive
)
Visual Basic
Function GetSpikes ( _
    chCoord As ChCoord, _
    fromFrameInclusive As Long, _
    toFrameExclusive As Long _
) As Long()
Visual C++
array<long long>^ GetSpikes(
    ChCoord^ chCoord,
    long long fromFrameInclusive,
    long long toFrameExclusive
)

Parameters

chCoord
Type: BW..::..ChCoord
The coordinates of the channels for which the deteted spikes are returned.
fromFrameInclusive
Type: System..::..Int64
The frame (included) where to start to search for spikes.
toFrameExclusive
Type: System..::..Int64
The frame (excluded) where to stop to search for spikes.

Return Value

An array of timestamps for the detected spikes for the given channel.

See Also

ISrcMeaFile Interface
GetSpikes Overload


GetSpikes Method (ChCoord[], Int64, Int64)

[image]

A Sandcastle Documented Class Library
ISrcMeaFile..::..GetSpikes Method (array<ChCoord>[]()[][], Int64, Int64)
ISrcMeaFile Interface See Also Send Feedback
Returns for every specified channel, an array of values representing the timestamps in number of frames of the spikes found within the given range.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
long[][] GetSpikes(
    ChCoord[] chCoords,
    long fromFrameInclusive,
    long toFrameExclusive
)
Visual Basic
Function GetSpikes ( _
    chCoords As ChCoord(), _
    fromFrameInclusive As Long, _
    toFrameExclusive As Long _
) As Long()()
Visual C++
array<array<long long>^>^ GetSpikes(
    array<ChCoord^>^ chCoords,
    long long fromFrameInclusive,
    long long toFrameExclusive
)

Parameters

chCoords
Type: array< BW..::..ChCoord >[]()[][]
An array cointaining the coordinates of the channels for which the deteted spikes are returned.
fromFrameInclusive
Type: System..::..Int64
The frame (included) where to start to search for spikes.
toFrameExclusive
Type: System..::..Int64
The frame (excluded) where to stop to search for spikes.

Return Value

An array where at each position is defined an array of timestamps for the detected spikes for the corresponding channel.

See Also

ISrcMeaFile Interface
GetSpikes Overload


GetTotNRecChs Method

[image]

A Sandcastle Documented Class Library
ISrcMeaFile..::..GetTotNRecChs Method
ISrcMeaFile Interface See Also Send Feedback
Returns the total number of recorded channels considering the union of the recorded channels for each existing streams.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
int GetTotNRecChs()
Visual Basic
Function GetTotNRecChs As Integer
Visual C++
int GetTotNRecChs()

Return Value

The total number of recorded channels.

See Also

ISrcMeaFile Interface


IsRawStreamFor Method

[image]

A Sandcastle Documented Class Library
ISrcMeaFile..::..IsRawStreamFor Method
ISrcMeaFile Interface See Also Send Feedback
Returns a value indicating whether a raw recorded stream exists for the specified channel.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
bool IsRawStreamFor(
    ChCoord chCoord
)
Visual Basic
Function IsRawStreamFor ( _
    chCoord As ChCoord _
) As Boolean
Visual C++
bool IsRawStreamFor(
    ChCoord^ chCoord
)

Parameters

chCoord
Type: BW..::..ChCoord
The channel coordinates.

Return Value

A value indicating whether a stream of raw type exist.

See Also

ISrcMeaFile Interface


IsSpikeStreamFor Method

[image]

A Sandcastle Documented Class Library
ISrcMeaFile..::..IsSpikeStreamFor Method
ISrcMeaFile Interface See Also Send Feedback
Returns a value indicating whether a spike recorded stream exists for the specified channel.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
bool IsSpikeStreamFor(
    ChCoord chCoord
)
Visual Basic
Function IsSpikeStreamFor ( _
    chCoord As ChCoord _
) As Boolean
Visual C++
bool IsSpikeStreamFor(
    ChCoord^ chCoord
)

Parameters

chCoord
Type: BW..::..ChCoord
The channel coordinates.

Return Value

A value indicating whether a stream of spike type exist.

See Also

ISrcMeaFile Interface


Open Method

[image]

A Sandcastle Documented Class Library
ISrcMeaFile..::..Open Method
ISrcMeaFile Interface See Also Send Feedback
Opens the specified BRW-file and return a value indicating the whether the opening was successful.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
bool Open(
    string filePath
)
Visual Basic
Function Open ( _
    filePath As String _
) As Boolean
Visual C++
bool Open(
    String^ filePath
)

Parameters

filePath
Type: System..::..String
The path of the BRW-file.

Return Value

Whether the file has been correctly opened.

See Also

ISrcMeaFile Interface


ISrcMeaFile Properties

[image] [image]

A Sandcastle Documented Class Library
ISrcMeaFile Properties
ISrcMeaFile Interface See Also Send Feedback

The ISrcMeaFile type exposes the following members.

Properties

 | Name | Description
Public property | BitDepth | Gets the number of bits used to represent a single sample (the levels of quantization, i.e. the signal resolution, are equal to 2 raised to the bit depth power).
Public property | MeaDeviceLayout | Gets the layout of the MEA device by setting to true the existing channel positions.
Public property | MeaDeviceLayoutNColumns | Get the number of columns of the MEA device layout.
Public property | MeaDeviceLayoutNRows | Gets the number of rows of the MEA device layout.
Public property | NBytesPerChSample | Gets the number of bytes used to store a sample into the hard disk.
Public property | NStreams | Gets the number of streams within the file.
Public property | RecDuration | Gets the duration in milliseconds of the acquired data.
Public property | RecNFrames | Gets the number of recorded frames.
Public property | SamplingRate | Returns the sampling frequency in Hz used to record data.
Public property | StreamTypes | Gets an array of StreamType ordered as the streams within the file.

See Also

ISrcMeaFile Interface


BitDepth Property

[image]

A Sandcastle Documented Class Library
ISrcMeaFile..::..BitDepth Property
ISrcMeaFile Interface See Also Send Feedback
Gets the number of bits used to represent a single sample (the levels of quantization, i.e. the signal resolution, are equal to 2 raised to the bit depth power).

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
int BitDepth { get; }
Visual Basic
ReadOnly Property BitDepth As Integer
    Get
Visual C++
property int BitDepth {
    int get ();
}

Return Value

The number of bits.

See Also

ISrcMeaFile Interface


MeaDeviceLayout Property

[image]

A Sandcastle Documented Class Library
ISrcMeaFile..::..MeaDeviceLayout Property
ISrcMeaFile Interface See Also Send Feedback
Gets the layout of the MEA device by setting to true the existing channel positions.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
bool[][] MeaDeviceLayout { get; }
Visual Basic
ReadOnly Property MeaDeviceLayout As Boolean()()
    Get
Visual C++
property array<array<bool>^>^ MeaDeviceLayout {
    array<array<bool>^>^ get ();
}

Return Value

A bidimensional array that specifies a MEA device layout with true values at existing channel positions.

See Also

ISrcMeaFile Interface


MeaDeviceLayoutNColumns Property

[image]

A Sandcastle Documented Class Library
ISrcMeaFile..::..MeaDeviceLayoutNColumns Property
ISrcMeaFile Interface See Also Send Feedback
Get the number of columns of the MEA device layout.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
int MeaDeviceLayoutNColumns { get; }
Visual Basic
ReadOnly Property MeaDeviceLayoutNColumns As Integer
    Get
Visual C++
property int MeaDeviceLayoutNColumns {
    int get ();
}

Return Value

The number of columns.

See Also

ISrcMeaFile Interface


MeaDeviceLayoutNRows Property

[image]

A Sandcastle Documented Class Library
ISrcMeaFile..::..MeaDeviceLayoutNRows Property
ISrcMeaFile Interface See Also Send Feedback
Gets the number of rows of the MEA device layout.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
int MeaDeviceLayoutNRows { get; }
Visual Basic
ReadOnly Property MeaDeviceLayoutNRows As Integer
    Get
Visual C++
property int MeaDeviceLayoutNRows {
    int get ();
}

Return Value

The number of rows.

See Also

ISrcMeaFile Interface


NBytesPerChSample Property

[image]

A Sandcastle Documented Class Library
ISrcMeaFile..::..NBytesPerChSample Property
ISrcMeaFile Interface See Also Send Feedback
Gets the number of bytes used to store a sample into the hard disk.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
int NBytesPerChSample { get; }
Visual Basic
ReadOnly Property NBytesPerChSample As Integer
    Get
Visual C++
property int NBytesPerChSample {
    int get ();
}

Return Value

The number of bytes for a single sample.

See Also

ISrcMeaFile Interface


NStreams Property

[image]

A Sandcastle Documented Class Library
ISrcMeaFile..::..NStreams Property
ISrcMeaFile Interface See Also Send Feedback
Gets the number of streams within the file.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
short NStreams { get; }
Visual Basic
ReadOnly Property NStreams As Short
    Get
Visual C++
property short NStreams {
    short get ();
}

See Also

ISrcMeaFile Interface


RecDuration Property

[image]

A Sandcastle Documented Class Library
ISrcMeaFile..::..RecDuration Property
ISrcMeaFile Interface See Also Send Feedback
Gets the duration in milliseconds of the acquired data.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
double RecDuration { get; }
Visual Basic
ReadOnly Property RecDuration As Double
    Get
Visual C++
property double RecDuration {
    double get ();
}

Return Value

The recording duration in milliseconds.

See Also

ISrcMeaFile Interface


RecNFrames Property

[image]

A Sandcastle Documented Class Library
ISrcMeaFile..::..RecNFrames Property
ISrcMeaFile Interface See Also Send Feedback
Gets the number of recorded frames.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
long RecNFrames { get; }
Visual Basic
ReadOnly Property RecNFrames As Long
    Get
Visual C++
property long long RecNFrames {
    long long get ();
}

Return Value

The number of recorded frames.

See Also

ISrcMeaFile Interface


SamplingRate Property

[image]

A Sandcastle Documented Class Library
ISrcMeaFile..::..SamplingRate Property
ISrcMeaFile Interface See Also Send Feedback
Returns the sampling frequency in Hz used to record data.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
int SamplingRate { get; }
Visual Basic
ReadOnly Property SamplingRate As Integer
    Get
Visual C++
property int SamplingRate {
    int get ();
}

Return Value

The sampling frequency.

See Also

ISrcMeaFile Interface


StreamTypes Property

[image]

A Sandcastle Documented Class Library
ISrcMeaFile..::..StreamTypes Property
ISrcMeaFile Interface See Also Send Feedback
Gets an array of StreamType ordered as the streams within the file.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
StreamType[] StreamTypes { get; }
Visual Basic
ReadOnly Property StreamTypes As StreamType()
    Get
Visual C++
property array<StreamType>^ StreamTypes {
    array<StreamType>^ get ();
}

See Also

ISrcMeaFile Interface


StreamType Enumeration

[image]

A Sandcastle Documented Class Library
StreamType Enumeration
See Also Send Feedback
Enumerates all the stream types that can be handled by the system.

Namespace: BW
Assembly: BrwExtReader (in BrwExtReader.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum StreamType
Visual Basic
Public Enumeration StreamType
Visual C++
public enum class StreamType

Members

Member name | Value | Description
Null | -1 | Represent a null (not available) stream.
Raw | 1 | Lossless raw data.
Spikes | 3 | Lossy spike data (timestamp and single value for each spike).

See Also

BW Namespace